<!DOCTYPE html><html lang="en-US"><head><meta charset="UTF-8"/><meta name="viewport" content="width=device-width, initial-scale=1"><link rel="profile" href="http://gmpg.org/xfn/11"/> <script>function fvmuag(){if(navigator.userAgent.match(/x11.*fox\/54|oid\s4.*xus.*ome\/62|oobot|ighth|tmetr|eadles|ingdo/i))return!1;if(navigator.userAgent.match(/x11.*ome\/75\.0\.3770\.100/i)){var e=screen.width,t=screen.height;if("number"==typeof e&&"number"==typeof t&&862==t&&1367==e)return!1}return!0}</script><title>Foster parents face special challenges during health crisis -</title><!-- This site is optimized with the Yoast SEO plugin v13.4.1 - https://yoast.com/wordpress/plugins/seo/ --><meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/><link rel="canonical" href="http://thechampionnewspaper.com/news/local/foster-parents-face-special-challenges-during-health-crisis/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Foster parents face special challenges during health crisis -" /><meta property="og:description" content="When Decatur-area resident Raquel Wilson and her husband decided to bring foster children into their home to care for along" /><meta property="og:url" content="http://thechampionnewspaper.com/news/local/foster-parents-face-special-challenges-during-health-crisis/" /><meta property="article:section" content="News" /><meta property="article:published_time" content="2020-05-08T13:04:24+00:00" /><meta property="article:modified_time" content="2020-05-08T13:04:25+00:00" /><meta property="og:updated_time" content="2020-05-08T13:04:25+00:00" /><meta property="og:image" content="http://thechampionnewspaper.com/wp-content/uploads/2020/05/95772705_719488378879939_8167568590443118592_n.jpg" /><meta property="og:image:width" content="1079" /><meta property="og:image:height" content="1329" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="When Decatur-area resident Raquel Wilson and her husband decided to bring foster children into their home to care for along" /><meta name="twitter:title" content="Foster parents face special challenges during health crisis -" /><meta name="twitter:image" content="http://thechampionnewspaper.com/wp-content/uploads/2020/05/95772705_719488378879939_8167568590443118592_n.jpg" /> <script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"http://thechampionnewspaper.com/#website","url":"http://thechampionnewspaper.com/","name":"","inLanguage":"en-US","potentialAction":[{"@type":"SearchAction","target":"http://thechampionnewspaper.com/?s={search_term_string}","query-input":"required name=search_term_string"}]},{"@type":"ImageObject","@id":"http://thechampionnewspaper.com/news/local/foster-parents-face-special-challenges-during-health-crisis/#primaryimage","inLanguage":"en-US","url":"http://thechampionnewspaper.com/wp-content/uploads/2020/05/95772705_719488378879939_8167568590443118592_n.jpg","width":1079,"height":1329},{"@type":"WebPage","@id":"http://thechampionnewspaper.com/news/local/foster-parents-face-special-challenges-during-health-crisis/#webpage","url":"http://thechampionnewspaper.com/news/local/foster-parents-face-special-challenges-during-health-crisis/","name":"Foster parents face special challenges during health crisis -","isPartOf":{"@id":"http://thechampionnewspaper.com/#website"},"inLanguage":"en-US","primaryImageOfPage":{"@id":"http://thechampionnewspaper.com/news/local/foster-parents-face-special-challenges-during-health-crisis/#primaryimage"},"datePublished":"2020-05-08T13:04:24+00:00","dateModified":"2020-05-08T13:04:25+00:00","author":{"@id":"http://thechampionnewspaper.com/#/schema/person/43ad557767f14a55585d020a3b8776fe"},"potentialAction":[{"@type":"ReadAction","target":["http://thechampionnewspaper.com/news/local/foster-parents-face-special-challenges-during-health-crisis/"]}]},{"@type":["Person"],"@id":"http://thechampionnewspaper.com/#/schema/person/43ad557767f14a55585d020a3b8776fe","name":"Kathy Mitchell","image":{"@type":"ImageObject","@id":"http://thechampionnewspaper.com/#authorlogo","inLanguage":"en-US","url":"http://0.gravatar.com/avatar/c796c49f9b9fa7086771b6a454b54fa6?s=96&d=wavatar&r=g","caption":"Kathy Mitchell"},"sameAs":[]}]}</script> <!-- / Yoast SEO plugin. --><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title=" &raquo; Feed" href="http://thechampionnewspaper.com/feed/" /><link rel="alternate" type="application/rss+xml" title=" &raquo; Comments Feed" href="http://thechampionnewspaper.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title=" &raquo; Foster parents face special challenges during health crisis Comments Feed" href="http://thechampionnewspaper.com/news/local/foster-parents-face-special-challenges-during-health-crisis/feed/" /> <!-- This site uses the Google Analytics by ExactMetrics plugin v6.0.2 - Using Analytics tracking - https://www.exactmetrics.com/ --> <script type="text/javascript" data-cfasync="false">var em_version         = '6.0.2';
	var em_track_user      = true;
	var em_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-126172677-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}

	if ( 'undefined' === typeof gaOptout ) {
		function gaOptout() {
			__gaTrackerOptout();
		}
	}
	
	if ( em_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

window.ga = __gaTracker;		__gaTracker('create', 'UA-126172677-1', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('send','pageview');
		__gaTracker( function() { window.ga = __gaTracker; } );
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + em_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
			window.ga = __gaTracker;		})();
		}</script> <!-- / Google Analytics by ExactMetrics --><style type="text/css" media="all">@font-face{font-family:'Open Sans';font-display:block;font-style:normal;font-weight:400;src:local('Open Sans Regular'),local('OpenSans-Regular'),url(http://fonts.gstatic.com/s/opensans/v17/mem8YaGs126MiZpBA-UFVZ0d.woff) format('woff')}@font-face{font-family:'Open Sans';font-display:block;font-style:normal;font-weight:600;src:local('Open Sans SemiBold'),local('OpenSans-SemiBold'),url(http://fonts.gstatic.com/s/opensans/v17/mem5YaGs126MiZpBA-UNirkOUuhv.woff) format('woff')}</style><link rel='stylesheet' id='fvm-header-0-css'  href='http://thechampionnewspaper.com/wp-content/uploads/cache/fvm/1586809618/out/header-8f3d33e0b106689ab6bc8408886a980806f4de57.min.css' type='text/css' media='all' /> <script type='text/javascript'>/*  */
var exactmetrics_frontend = {"js_events_tracking":"true","download_extensions":"zip,mp3,mpeg,pdf,docx,pptx,xlsx,rar","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"http:\/\/thechampionnewspaper.com","hash_tracking":"false"};
/*  */</script> <script type='text/javascript' src='http://thechampionnewspaper.com/wp-content/uploads/cache/fvm/1586809618/out/header-321d6b4d82f4be39d13c2f97e230875056bd109d.min.js'></script><!--[if lte IE 8]> <script type='text/javascript' src='http://thechampionnewspaper.com/wp-content/themes/colormag/js/html5shiv.min.js'></script> <![endif]--><link rel='https://api.w.org/' href='http://thechampionnewspaper.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://thechampionnewspaper.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://thechampionnewspaper.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.3.3" /><link rel='shortlink' href='http://thechampionnewspaper.com/?p=28239' /><link rel="alternate" type="application/json+oembed" href="http://thechampionnewspaper.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fthechampionnewspaper.com%2Fnews%2Flocal%2Ffoster-parents-face-special-challenges-during-health-crisis%2F" /><link rel="alternate" type="text/xml+oembed" href="http://thechampionnewspaper.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fthechampionnewspaper.com%2Fnews%2Flocal%2Ffoster-parents-face-special-challenges-during-health-crisis%2F&#038;format=xml" /><meta property="fb:app_id" content=""/><style media="screen">.simplesocialbuttons.simplesocialbuttons_inline .ssb-fb-like { margin: ; } /*inline margin*/ .simplesocialbuttons.simplesocialbuttons_inline.simplesocial-simple-round button{ margin: ; } /*margin-digbar*/</style><!-- Open Graph Meta Tags generated by Simple Social Buttons 3.1.1 --><meta property="og:title" content="Foster parents face special challenges during health crisis - " /><meta property="og:description" content="When Decatur-area resident Raquel Wilson and her husband decided to bring foster children into their home to care for along with their two biological children, officials from the foster care system never promised it would be easy, Wilson said. Still, she never imagined the challenges a pandemic would bring.“They don’t sugar coat
it,” Wilson said of the preparation to bring foster" /><meta property="og:url" content="http://thechampionnewspaper.com/news/local/foster-parents-face-special-challenges-during-health-crisis/" /><meta property="og:image" content="http://thechampionnewspaper.com/wp-content/uploads/2020/05/95772705_719488378879939_8167568590443118592_n.jpg" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="When Decatur-area resident Raquel Wilson and her husband decided to bring foster children into their home to care for along with their two biological children, officials from the foster care system never promised it would be easy, Wilson said. Still, she never imagined the challenges a pandemic would bring.“They don’t sugar coat
it,” Wilson said of the preparation to bring foster" /><meta name="twitter:title" content="Foster parents face special challenges during health crisis - " /><meta property="twitter:image" content="http://thechampionnewspaper.com/wp-content/uploads/2020/05/95772705_719488378879939_8167568590443118592_n.jpg" /><link rel="pingback" href="http://thechampionnewspaper.com/xmlrpc.php"><style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style><script type="text/javascript" src="https://www.w3counter.com/tracker.js?id=84242&wphead=true"></script> <link rel="icon" href="http://thechampionnewspaper.com/wp-content/uploads/2018/09/cropped-512championlogo-2-32x32.jpg" sizes="32x32" /><link rel="icon" href="http://thechampionnewspaper.com/wp-content/uploads/2018/09/cropped-512championlogo-2-192x192.jpg" sizes="192x192" /><link rel="apple-touch-icon-precomposed" href="http://thechampionnewspaper.com/wp-content/uploads/2018/09/cropped-512championlogo-2-180x180.jpg" /><meta name="msapplication-TileImage" content="http://thechampionnewspaper.com/wp-content/uploads/2018/09/cropped-512championlogo-2-270x270.jpg" /></head><body class="post-template-default single single-post postid-28239 single-format-standard "><div id="page" class="hfeed site"> <header id="masthead" class="site-header clearfix "><div id="header-text-nav-container" class="clearfix"><div class="news-bar"><div class="inner-wrap clearfix"><div class="breaking-news"> <strong class="breaking-news-latest">Latest:</strong><ul class="newsticker"><li> <a href="http://thechampionnewspaper.com/news/local/foster-parents-face-special-challenges-during-health-crisis/"
title="Foster parents face special challenges during health crisis">Foster parents face special challenges during health crisis</a></li><li> <a href="http://thechampionnewspaper.com/news/local/fighting-together/"
title="Fighting together">Fighting together</a></li><li> <a href="http://thechampionnewspaper.com/news/local/clarkston-covid-19-task-force-releases-testing-locations/"
title="Clarkston COVID-19 task force releases testing locations">Clarkston COVID-19 task force releases testing locations</a></li><li> <a href="http://thechampionnewspaper.com/news/local/dekalbs-summer-jobs-program-to-go-virtual-registration-opens-may-8/"
title="DeKalb’s summer jobs program to go virtual, registration opens May 8">DeKalb’s summer jobs program to go virtual, registration opens May 8</a></li><li> <a href="http://thechampionnewspaper.com/news/local/blessed-restaurant-owner-sends-thank-you-meals-to-healthcare-workers/"
title="‘Blessed’ restaurant owner sends thank-you meals to healthcare workers">‘Blessed’ restaurant owner sends thank-you meals to healthcare workers</a></li></ul></div></div></div><div class="inner-wrap"><div id="header-text-nav-wrap" class="clearfix"><div id="header-left-section"><div id="header-logo-image"></div><!-- #header-logo-image --><div id="header-text" class="screen-reader-text"><h3 id="site-title"> <a href="http://thechampionnewspaper.com/" title="" rel="home"></a></h3> <!-- #site-description --></div><!-- #header-text --></div><!-- #header-left-section --><div id="header-right-section"></div><!-- #header-right-section --></div><!-- #header-text-nav-wrap --></div><!-- .inner-wrap --><div id="wp-custom-header" class="wp-custom-header"><div class="header-image-wrap"><img src="http://thechampionnewspaper.com/wp-content/uploads/2019/04/cropped-new-logo.png" class="header-image" width="1048" height="224" alt=""></div></div> <nav id="site-navigation" class="main-navigation clearfix" role="navigation"><div class="inner-wrap clearfix"><div class="home-icon"> <a href="http://thechampionnewspaper.com/" title=""><i class="fa fa-home"></i></a></div><p class="menu-toggle"></p><div class="menu-primary-container"><ul id="menu-blank" class="menu"><li id="menu-item-21507" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-21507"><a href="http://thechampionnewspaper.com/">Home</a></li><li id="menu-item-22299" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-22299"><a href="http://thechampionnewspaper.com/advertise/">Advertise</a></li><li id="menu-item-21499" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-21499"><a href="http://thechampionnewspaper.com/news/local/category/news-dekalb/">News</a><ul class="sub-menu"><li id="menu-item-21511" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21511"><a href="http://thechampionnewspaper.com/events-calendar/">Around DeKalb</a></li><li id="menu-item-21505" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21505"><a href="http://thechampionnewspaper.com/news/local/category/business/">Business</a></li><li id="menu-item-21506" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-21506"><a href="http://thechampionnewspaper.com/news/local/category/community-cities/">Cities</a><ul class="sub-menu"><li id="menu-item-25741" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25741"><a href="http://thechampionnewspaper.com/news/local/category/community-cities/brookhaven/">Brookhaven</a></li><li id="menu-item-25742" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25742"><a href="http://thechampionnewspaper.com/news/local/category/community-cities/chamblee/">Chamblee</a></li><li id="menu-item-25743" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25743"><a href="http://thechampionnewspaper.com/news/local/category/community-cities/clarkston/">Clarkston</a></li><li id="menu-item-25755" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25755"><a href="http://thechampionnewspaper.com/news/local/category/community-cities/government-countywide/">Countywide</a></li><li id="menu-item-25744" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25744"><a href="http://thechampionnewspaper.com/news/local/category/community-cities/decatur/">Decatur</a></li><li id="menu-item-25745" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25745"><a href="http://thechampionnewspaper.com/news/local/category/community-cities/doraville/">Doraville</a></li><li id="menu-item-25759" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25759"><a href="http://thechampionnewspaper.com/news/local/category/community-cities/dunwoody/">Dunwoody</a></li><li id="menu-item-25746" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25746"><a href="http://thechampionnewspaper.com/news/local/category/community-cities/ellenwood/">Ellenwood</a></li><li id="menu-item-25758" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25758"><a href="http://thechampionnewspaper.com/news/local/category/community-cities/lithonia/">Lithonia</a></li><li id="menu-item-25747" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25747"><a href="http://thechampionnewspaper.com/news/local/category/community-cities/stonecrest/">Stonecrest</a></li><li id="menu-item-25748" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25748"><a href="http://thechampionnewspaper.com/news/local/category/community-cities/tucker-community/">Tucker</a></li></ul></li><li id="menu-item-22779" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22779"><a href="http://thechampionnewspaper.com/news/local/category/editorial/">Editorial</a></li><li id="menu-item-21501" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21501"><a href="http://thechampionnewspaper.com/news/local/category/education/">Education</a></li><li id="menu-item-25760" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25760"><a href="http://thechampionnewspaper.com/news/local/category/freepress/">Freepress</a></li><li id="menu-item-21502" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21502"><a href="http://thechampionnewspaper.com/news/local/category/lifestyle/">Lifestyle</a></li><li id="menu-item-21503" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21503"><a href="http://thechampionnewspaper.com/news/local/category/opinion/">Opinion</a></li></ul></li><li id="menu-item-25765" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-25765"><a href="http://thechampionnewspaper.com/free-press-archives/">DeKalb Free Press</a></li><li id="menu-item-21500" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-21500"><a href="http://thechampionnewspaper.com/news/local/category/sports/">Sports</a><ul class="sub-menu"><li id="menu-item-25737" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25737"><a href="http://thechampionnewspaper.com/news/local/category/sports/baseball/">Baseball</a></li><li id="menu-item-25738" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25738"><a href="http://thechampionnewspaper.com/news/local/category/sports/basketball/">Basketball</a></li><li id="menu-item-25739" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25739"><a href="http://thechampionnewspaper.com/news/local/category/sports/football/">Football</a></li><li id="menu-item-25740" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25740"><a href="http://thechampionnewspaper.com/news/local/category/sports/soccer/">Soccer</a></li></ul></li><li id="menu-item-25754" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-25754"><a href="http://thechampionnewspaper.com/legal-login-advertising/">Legal Advertising Dept</a></li><li id="menu-item-21508" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21508"><a href="http://thechampionnewspaper.com/contact-us/">Contact Us</a></li><li id="menu-item-21464" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21464"><a href="http://thechampionnewspaper.com/locationsnewsstands/">Locations</a></li><li id="menu-item-25752" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-25752"><a href="http://thechampionnewspaper.com/subscribe-2/">Subscribe</a></li></ul></div> <i class="fa fa-search search-top"></i><div class="search-form-top"><form action="http://thechampionnewspaper.com/" class="search-form searchform clearfix" method="get"><div class="search-wrap"> <input type="text" placeholder="Search" class="s field" name="s"> <button class="search-icon" type="submit"></button></div></form><!-- .searchform --></div></div> </nav></div><!-- #header-text-nav-container --> </header><div id="main" class="clearfix"><div class="inner-wrap clearfix"><div id="primary"><div id="content" class="clearfix"> <article id="post-28239" class="post-28239 post type-post status-publish format-standard has-post-thumbnail hentry category-news-dekalb"><div class="featured-image"> <img width="800" height="445" src="http://thechampionnewspaper.com/wp-content/uploads/2020/05/95772705_719488378879939_8167568590443118592_n-800x445.jpg" class="attachment-colormag-featured-image size-colormag-featured-image wp-post-image" alt="" /></div><div class="article-content clearfix"><div class="above-entry-meta"><span class="cat-links"><a href="http://thechampionnewspaper.com/news/local/category/news-dekalb/"  rel="category tag">News</a>&nbsp;</span></div> <header class="entry-header"><h1 class="entry-title"> Foster parents face special challenges during health crisis</h1> </header><div class="below-entry-meta"> <span class="posted-on"><a href="http://thechampionnewspaper.com/news/local/foster-parents-face-special-challenges-during-health-crisis/" title="9:04 am" rel="bookmark"><i class="fa fa-calendar-o"></i> <time class="entry-date published" datetime="2020-05-08T09:04:24-04:00">May 8, 2020</time><time class="updated" datetime="2020-05-08T09:04:25-04:00">May 8, 2020</time></a></span> <span class="byline"> <span class="author vcard"> <i class="fa fa-user"></i> <a class="url fn n"
href="http://thechampionnewspaper.com/news/local/author/kathy-mitchell/"
title="Kathy Mitchell">Kathy Mitchell </a> </span> </span><span class="comments"><a href="http://thechampionnewspaper.com/news/local/foster-parents-face-special-challenges-during-health-crisis/#respond"><i class="fa fa-comment"></i> 0 Comments</a></span></div><div class="entry-content clearfix"><p>When Decatur-area resident <strong>Raquel Wilson</strong> and her husband decided to bring foster children into their home to care for along with their two biological children, officials from the foster care system never promised it would be easy, Wilson said. Still, she never imagined the challenges a pandemic would bring.</p><p>“They don’t sugar coat
it,” Wilson said of the preparation to bring foster children into her home. “We
knew that in addition to providing everyday care for the children we would have
to arrange meetings with case workers, social workers and the children’s
biological family. We knew many of the children in foster care had lived
through some rough home situations and might need special care, but even the
challenges we already had multiplied when we had to deal with the need to
safeguard everyone’s health during a situation unlike anything any of us had
ever lived through.”</p><p>Approximately 820 DeKalb
County children are currently in foster homes, though 70 percent are placed
outside the county, according to Wellroot, the Decatur-based, faith-centered
nonprofit through which Wilson arranged foster parenting. Wellroot’s mission is
to restore families where children have been forced by circumstances to be
separated from their parents. Some foster children are kinship placements
through which children live with extended family and others, as in Wilson’s
case, are traditional placements with families with which the children have no
prior relationship.</p><p>Wellroot’s goal is to
restore children to their biological parents whenever it’s possible to do so
with assurance that the children are being returned to a safe, healthy
environment. While the children are in foster care, an effort is made to do what
Wilson calls “partnership parenting,” which keeps biological parents involved in
rearing the children and may include periodic visits with them.</p><p>Wilson said her decision
to become a foster parent was prompted by a desire to help others. “I realized
that I’ve been fortunate while many around me are struggling,” she recalled. “I
wanted to do more than write a check or volunteer part time. I looked into
foster parenting and realized that in Georgia more than 14,000 children are in
foster care. I found that number staggering. I knew that was where I could
help.”</p><p>After discussing the
situation with her husband, Wilson said the couple agreed to take the training
required to become foster parents. “The same day we were accepted into the
program we got a call telling us they had children for us. The children arrived
that evening.” The Wilsons have been foster parents to six children at various
times since they entered the program three years ago. They currently have one
preschool foster child.</p><p>Wilson owns a business
that she had been operating primarily from a coworking facility, though she had
been working some from home. “Now it all has to be done from home. At the
coworking office, which is closed because of the health crisis, I wasn’t
distracted by caring for the children while I worked; they were at school or in
daycare. Now we’re all together all the time.”</p><p>The daycare center where
Wilson’s 10-month-old foster child had spent most days has closed until the
health crisis is over. &nbsp;Like many parents
of school-age children, Wilson was suddenly thrust into a dual role—parent and
teacher after schools closed and lessons continued online. The meetings with
others involved in the foster child’s life had to become virtual meetings. The
child Wilson is currently fostering requires physical therapy and that too must
be done online.</p><p>Wilson describes herself
as a high-energy person who normally is up early every day and is not fazed by
a busy schedule. Still, she said, the current situation has changed nearly
every aspect of her home and work life.</p><p>“I am more fortunate than
many foster parents in several respects,” Wilson commented. “My background includes
10 years in social work, though not in child welfare. Also, as the head of my
company, I am more in control of my schedule than most working people.</p><p>“No matter how difficult
this is for adults, the disruption of routine and the uncertainly as to when
and how this will end is truly difficult for children, particularly children
who already have endured a good deal of instability in their lives. My goal is
for our family—whether temporary or permanent—to come out of this physically
and emotionally healthy.”</p><div class="pvc_clear"></div><p class="pvc_stats" element-id="28239">48&nbsp;total views, 48&nbsp;views today</p><div class="pvc_clear"></div><input id="wpsocial-get-post-id" type="hidden" value="http://thechampionnewspaper.com/news/local/foster-parents-face-special-challenges-during-health-crisis/" /><div id="wpsocial-social-icons-box" class="wpsocial-social-icons-box" data-selected-skin="" style="display: block;width: 100%;background-color: ;" id="wpsocial-live-preview-options-settings"></div><input id="wpsocial-selected-social-network1" name="wpsocial-selcetion-network" type="hidden" value="wpsocial-facebook"></input><input id="wpsocial-selected-social-network2" name="wpsocial-selcetion-network" type="hidden" value="wpsocial-twitter"></input><input id="wpsocial-selected-social-network3" name="wpsocial-selcetion-network" type="hidden" value="wpsocial-google"></input><input id="wpsocial-selected-social-network4" name="wpsocial-selcetion-network" type="hidden" value=""></input><input id="wpsocial-selected-social-network5" name="wpsocial-selcetion-network" type="hidden" value="wpsocial-pinterest"></input><input id="wpsocial-selected-skin" type="hidden" value=""/><input id="wpsocial-selected-positioning" type="hidden" value="afterpost"/><input id="wpsocial-selected-message" type="hidden" value="None"/><input id="wpsocial-selected-custom-message" type="hidden" value=""/><input id="wpsocial-selected-alignment" type="hidden" value=""/><input id="wpsocial-selected-message-font" type="hidden" value=""/><div id="wpdevar_comment_3" style="width:100%;text-align:left;"> <span style="padding: 10px;font-size:15px;font-family:Times New Roman,Times,Serif,Georgia;color:#000000;">Facebook Comments</span><div class="fb-comments" data-href="http://thechampionnewspaper.com/news/local/foster-parents-face-special-challenges-during-health-crisis/" data-order-by="social" data-numposts="5" data-width="100%" style="display:block;"></div></div><style>#wpdevar_comment_3 span,#wpdevar_comment_3 iframe{width:100% !important;}</style><div class="simplesocialbuttons simplesocial-simple-round simplesocialbuttons_inline simplesocialbuttons-align-left post-28239 post  simplesocialbuttons-inline-no-animation"> <button class="simplesocial-fb-share" target="_blank" data-href="https://www.facebook.com/sharer/sharer.php?u=http://thechampionnewspaper.com/news/local/foster-parents-face-special-challenges-during-health-crisis/" onclick="javascript:window.open(this.dataset.href, '', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><span class="simplesocialtxt">Facebook </span> </button> <button class="simplesocial-twt-share" data-href="https://twitter.com/share?text=Foster+parents+face+special+challenges+during+health+crisis&url=http://thechampionnewspaper.com/news/local/foster-parents-face-special-challenges-during-health-crisis/" rel="nofollow" onclick="javascript:window.open(this.dataset.href, '', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><span class="simplesocialtxt">Twitter</span> </button> <button class="simplesocial-reddit-share"  data-href="https://reddit.com/submit?url=http://thechampionnewspaper.com/news/local/foster-parents-face-special-challenges-during-health-crisis/&title=Foster+parents+face+special+challenges+during+health+crisis" onclick="javascript:window.open(this.dataset.href, '', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;" ><span class="simplesocialtxt">Reddit</span> </button> <button target="popup" class="simplesocial-linkedin-share" data-href="https://www.linkedin.com/cws/share?url=http://thechampionnewspaper.com/news/local/foster-parents-face-special-challenges-during-health-crisis/" onclick="javascript:window.open(this.dataset.href, '', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><span class="simplesocialtxt">LinkedIn</span></button> <button onclick="javascript:window.location.href = this.dataset.href;return false;" class="simplesocial-email-share" data-href="mailto:?subject=Foster+parents+face+special+challenges+during+health+crisis&body=http://thechampionnewspaper.com/news/local/foster-parents-face-special-challenges-during-health-crisis/"><span class="simplesocialtxt">Email</span></button><div class="fb-like ssb-fb-like" data-href="http://thechampionnewspaper.com/news/local/foster-parents-face-special-challenges-during-health-crisis/" data-layout="button_count" data-action="like" data-size="small" data-show-faces="false" data-share="false"></div></div></div></div></article></div><!-- #content --><ul class="default-wp-page clearfix"><li class="previous"><a href="http://thechampionnewspaper.com/news/local/fighting-together/" rel="prev"><span class="meta-nav">&larr;</span> Fighting together</a></li><li class="next"></li></ul><h4 class="related-posts-main-title"><i class="fa fa-thumbs-up"></i><span>You May Also Like</span></h4><div class="related-posts clearfix"><div class="single-related-posts"><div class="related-posts-thumbnail"> <a href="http://thechampionnewspaper.com/news/local/college-learning-labs-support-learners/" title="College learning labs support learners"> <img width="273" height="205" src="http://thechampionnewspaper.com/wp-content/uploads/2013/12/IMG_4386.jpg" class="attachment-colormag-featured-post-medium size-colormag-featured-post-medium wp-post-image" alt="" srcset="http://thechampionnewspaper.com/wp-content/uploads/2013/12/IMG_4386.jpg 600w, http://thechampionnewspaper.com/wp-content/uploads/2013/12/IMG_4386-200x150.jpg 200w, http://thechampionnewspaper.com/wp-content/uploads/2013/12/IMG_4386-100x75.jpg 100w" sizes="(max-width: 273px) 100vw, 273px" /> </a></div><div class="article-content"><h3 class="entry-title"> <a href="http://thechampionnewspaper.com/news/local/college-learning-labs-support-learners/" rel="bookmark" title="College learning labs support learners">College learning labs support learners</a></h3><!--/.post-title--><div class="below-entry-meta"> <span class="posted-on"><a href="http://thechampionnewspaper.com/news/local/college-learning-labs-support-learners/" title="11:35 am" rel="bookmark"><i class="fa fa-calendar-o"></i> <time class="entry-date published" datetime="2013-12-23T11:35:28-05:00">December 23, 2013</time></a></span> <span class="byline"><span class="author vcard"><i class="fa fa-user"></i><a class="url fn n" href="http://thechampionnewspaper.com/news/local/author/andrew-cauthen/" title="Andrew Cauthen">Andrew Cauthen</a></span></span> <span class="comments"><i class="fa fa-comment"></i><a href="http://thechampionnewspaper.com/news/local/college-learning-labs-support-learners/#comments">1</a></span></div></div></div><!--/.related--><div class="single-related-posts"><div class="related-posts-thumbnail"> <a href="http://thechampionnewspaper.com/news/local/manhunt-continues-for-lawyer-accused-of-mothers-murder/" title="Manhunt continues for lawyer accused of mother’s murder"> <img width="273" height="205" src="http://thechampionnewspaper.com/wp-content/uploads/2019/02/DSCN6195.jpg" class="attachment-colormag-featured-post-medium size-colormag-featured-post-medium wp-post-image" alt="" srcset="http://thechampionnewspaper.com/wp-content/uploads/2019/02/DSCN6195.jpg 640w, http://thechampionnewspaper.com/wp-content/uploads/2019/02/DSCN6195-200x150.jpg 200w, http://thechampionnewspaper.com/wp-content/uploads/2019/02/DSCN6195-600x450.jpg 600w, http://thechampionnewspaper.com/wp-content/uploads/2019/02/DSCN6195-500x375.jpg 500w, http://thechampionnewspaper.com/wp-content/uploads/2019/02/DSCN6195-326x245.jpg 326w, http://thechampionnewspaper.com/wp-content/uploads/2019/02/DSCN6195-80x60.jpg 80w, http://thechampionnewspaper.com/wp-content/uploads/2019/02/DSCN6195-100x75.jpg 100w" sizes="(max-width: 273px) 100vw, 273px" /> </a></div><div class="article-content"><h3 class="entry-title"> <a href="http://thechampionnewspaper.com/news/local/manhunt-continues-for-lawyer-accused-of-mothers-murder/" rel="bookmark" title="Manhunt continues for lawyer accused of mother’s murder">Manhunt continues for lawyer accused of mother’s murder</a></h3><!--/.post-title--><div class="below-entry-meta"> <span class="posted-on"><a href="http://thechampionnewspaper.com/news/local/manhunt-continues-for-lawyer-accused-of-mothers-murder/" title="12:23 pm" rel="bookmark"><i class="fa fa-calendar-o"></i> <time class="entry-date published" datetime="2019-02-13T12:23:09-05:00">February 13, 2019</time></a></span> <span class="byline"><span class="author vcard"><i class="fa fa-user"></i><a class="url fn n" href="http://thechampionnewspaper.com/news/local/author/horace-holloman/" title="Horace Holloman">Horace Holloman</a></span></span> <span class="comments"><i class="fa fa-comment"></i><a href="http://thechampionnewspaper.com/news/local/manhunt-continues-for-lawyer-accused-of-mothers-murder/#respond">0</a></span></div></div></div><!--/.related--><div class="single-related-posts"><div class="related-posts-thumbnail"> <a href="http://thechampionnewspaper.com/news/local/burrell-ellis-on-trial-again/" title="Burrell Ellis on trial again"> <img width="273" height="205" src="http://thechampionnewspaper.com/wp-content/uploads/2015/06/IMG_0264.jpg" class="attachment-colormag-featured-post-medium size-colormag-featured-post-medium wp-post-image" alt="" srcset="http://thechampionnewspaper.com/wp-content/uploads/2015/06/IMG_0264.jpg 3648w, http://thechampionnewspaper.com/wp-content/uploads/2015/06/IMG_0264-200x150.jpg 200w, http://thechampionnewspaper.com/wp-content/uploads/2015/06/IMG_0264-1024x768.jpg 1024w, http://thechampionnewspaper.com/wp-content/uploads/2015/06/IMG_0264-100x75.jpg 100w" sizes="(max-width: 273px) 100vw, 273px" /> </a></div><div class="article-content"><h3 class="entry-title"> <a href="http://thechampionnewspaper.com/news/local/burrell-ellis-on-trial-again/" rel="bookmark" title="Burrell Ellis on trial again">Burrell Ellis on trial again</a></h3><!--/.post-title--><div class="below-entry-meta"> <span class="posted-on"><a href="http://thechampionnewspaper.com/news/local/burrell-ellis-on-trial-again/" title="1:32 pm" rel="bookmark"><i class="fa fa-calendar-o"></i> <time class="entry-date published" datetime="2015-06-09T13:32:07-04:00">June 9, 2015</time></a></span> <span class="byline"><span class="author vcard"><i class="fa fa-user"></i><a class="url fn n" href="http://thechampionnewspaper.com/news/local/author/andrew-cauthen/" title="Andrew Cauthen">Andrew Cauthen</a></span></span> <span class="comments"><i class="fa fa-comment"></i><a href="http://thechampionnewspaper.com/news/local/burrell-ellis-on-trial-again/#respond">0</a></span></div></div></div><!--/.related--></div><!--/.post-related--><div id="comments" class="comments-area"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/news/local/foster-parents-face-special-challenges-during-health-crisis/?utm_source=rss&amp;utm_medium=rss&amp;utm_campaign=foster-parents-face-special-challenges-during-health-crisis#respond" style="display:none;">Cancel reply</a></small></h3><form action="http://thechampionnewspaper.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p><p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p><p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p><p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='28239' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="3ace28ac06" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="110"/></p></form></div><!-- #respond --></div><!-- #comments --></div><!-- #primary --><div id="secondary"> <aside id="colormag_300x250_advertisement_widget-3" class="widget widget_300x250_advertisement clearfix"><div class="advertisement_300x250"><div class="advertisement-content"><a href="http://www.dekalbtax.org" class="single_ad_300x250" target="_blank" rel="nofollow"> <img src="http://thechampionnewspaper.com/wp-content/uploads/2020/04/Erik-DeKalb-County-Tax-Commissioner-COVID-19-Champion-Sidebar-4-28-20.jpg" width="300" height="250" alt=""> </a></div></div> </aside><aside id="custom_html-8" class="widget_text widget widget_custom_html clearfix"><h3 class="widget-title"><span>CLICK THE SUBSCRIBE BUTTON TO PURCHASE THE CURRENT ISSUE OF THE CHAMPION NEWSPAPER</span></h3><div class="textwidget custom-html-widget"><form action="https://www.paypal.com/cgi-bin/webscr" method="post" target="_top"> <input type="hidden" name="cmd" value="_s-xclick"> <input type="hidden" name="hosted_button_id" value="RWNJH3DAWVNKY"><table><tr><td><input type="hidden" name="on0" value="Current issue of The Champion">Current issue of The Champion</td></tr><tr><td><input type="text" name="os0" maxlength="200"></td></tr></table> <input type="image" src="https://www.paypalobjects.com/en_US/i/btn/btn_subscribeCC_LG.gif" border="0" name="submit" alt="PayPal - The safer, easier way to pay online!"> <img alt="" border="0" src="https://www.paypalobjects.com/en_US/i/scr/pixel.gif" width="1" height="1"></form></div></aside><aside id="media_image-14" class="widget widget_media_image clearfix"><img width="426" height="462" src="http://thechampionnewspaper.com/wp-content/uploads/2020/03/OfficeClosing-1.jpg" class="image wp-image-27516  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="http://thechampionnewspaper.com/wp-content/uploads/2020/03/OfficeClosing-1.jpg 426w, http://thechampionnewspaper.com/wp-content/uploads/2020/03/OfficeClosing-1-184x200.jpg 184w" sizes="(max-width: 426px) 100vw, 426px" /></aside><aside id="search-2" class="widget widget_search clearfix"><form action="http://thechampionnewspaper.com/" class="search-form searchform clearfix" method="get"><div class="search-wrap"> <input type="text" placeholder="Search" class="s field" name="s"> <button class="search-icon" type="submit"></button></div></form><!-- .searchform --></aside><aside id="recent-comments-4" class="widget widget_recent_comments clearfix"><h3 class="widget-title"><span>Recent Comments</span></h3><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link">Estrella</span> on <a href="http://thechampionnewspaper.com/news/local/dekalbs-summer-jobs-program-to-go-virtual-registration-opens-may-8/#comment-616318">DeKalb’s summer jobs program to go virtual, registration opens May 8</a></li><li class="recentcomments"><span class="comment-author-link">ARM</span> on <a href="http://thechampionnewspaper.com/news/local/stonecrest-recognized-for-finance-reporting/#comment-616317">Stonecrest recognized for finance reporting</a></li><li class="recentcomments"><span class="comment-author-link"><a href='http://exifinty' rel='external nofollow ugc' class='url'>Mayron Miheret</a></span> on <a href="http://thechampionnewspaper.com/news/local/tucker-middle-now-stem-certified/#comment-616281">Tucker Middle now STEM certified</a></li><li class="recentcomments"><span class="comment-author-link">Sheree Scott</span> on <a href="http://thechampionnewspaper.com/news/local/stonecrest-begins-repaving-roads/#comment-616274">Stonecrest begins repaving roads</a></li><li class="recentcomments"><span class="comment-author-link">Bruce</span> on <a href="http://thechampionnewspaper.com/news/local/dekalb-launches-vacant-property-registry/#comment-616273">DeKalb launches vacant property registry</a></li></ul></aside></div></div><!-- .inner-wrap --></div><!-- #main --><footer id="colophon" class="clearfix "><div class="footer-socket-wrapper clearfix"><div class="inner-wrap"><div class="footer-socket-area"><div class="footer-socket-right-section"></div><div class="footer-socket-left-section"><div class="copyright">Copyright &copy; 2020 <a href="http://thechampionnewspaper.com/" title="" ><span></span></a>. All rights reserved.<br>Theme: ColorMag by <a href="https://themegrill.com/themes/colormag" target="_blank" title="ThemeGrill" rel="author"><span>ThemeGrill</span></a>. Powered by <a href="https://wordpress.org" target="_blank" title="WordPress"><span>WordPress</span></a>.</div></div></div></div></div> </footer><a href="#masthead" id="scroll-up"><i class="fa fa-chevron-up"></i></a></div><!-- #page --><div id="fb-root"></div> <script>(function(d, s, id) {
          var js, fjs = d.getElementsByTagName(s)[0];
          if (d.getElementById(id)) return;
          js = d.createElement(s); js.id = id;
          js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=&version=v2.3";
          fjs.parentNode.insertBefore(js, fjs);
        }(document, 'script', 'facebook-jssdk'));</script> <div id="fb-root"></div> <script>(function(d, s, id) {
			var js, fjs = d.getElementsByTagName(s)[0];
			if (d.getElementById(id)) return;
			js = d.createElement(s); js.id = id;
			js.src = 'https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.11&appId=1158761637505872';
			fjs.parentNode.insertBefore(js, fjs);
		}(document, 'script', 'facebook-jssdk'));</script> <link rel='stylesheet' id='fvm-footer-0-css'  href='http://thechampionnewspaper.com/wp-content/uploads/cache/fvm/1586809618/out/footer-584773cd318e81a97e6a5d02ea6885ae6f2ea36c.min.css' type='text/css' media='all' /> <script type='text/javascript'>/*  */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"http:\/\/thechampionnewspaper.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/*  */</script> <script type='text/javascript' src='http://thechampionnewspaper.com/wp-content/uploads/cache/fvm/1586809618/out/footer-2c3186b7bfbdf7379b2211a82535ef91f435cebe.min.js'></script><script type='text/javascript'>function initTwitCount(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://static1.twitcount.com/js/twitcount.js';fjs.parentNode.insertBefore(js,fjs)}}
        var ssb_twit_count_init=!1;addEventListener('mouseover',function(event){if(!ssb_twit_count_init){initTwitCount(document,'script','twitcount_plugins')
        ssb_twit_count_init=!0}})</script><script async type="text/javascript" src="/_Incapsula_Resource?SWJIYLWA=719d34d31c8e3a6e6fffd425f7e032f3&ns=2&cb=1672942039"></script>
</body></html>